Hướng dẫn cấu hình Dynamic DNS cho router Mikrotik trên os.gftth.com

DDNS hay Dynamic DNS là phương thức ánh xạ tên miền tới địa chỉ IP có tần suất thay đổi cao (do không phải mọi khách hàng dùng mạng Internet đều có IP tĩnh). Dịch vụ DNS động cung cấp một chương trình đặc biệt chạy trên thiết bị của người sử dụng một dịch vụ gọi là Dynamic DNS Client. Chương trình này giám sát sự thay đổi địa chỉ IP tại máy chủ cần cài đặt dịch vụ web, mail,… và liên hệ với hệ thống DNS mỗi khi địa chỉ IP của nó (vốn được cung cấp bởi các nhà cung cấp dịch vụ mạng bằng phương pháp động) thay đổi và sau đó cập nhật thông tin vào cơ sở dữ liệu DNS về sự thay đổi địa chỉ đó. Bằng cách này, cho dù máy chủ có thường xuyên bị thay đổi địa chỉ thì tên miền vẫn được hệ thống máy chủ DNS trỏ về đúng địa chỉ được cấp IP mới đó.

DDNS thường được ứng dụng cho một số dịch vụ không cần thiết phải có IP tĩnh (vì chi phí để có IP tĩnh khá đắt đỏ) như xem Camera, VPN,…

Cũng giống như nhiều router khác, Mikrotik cung cấp tính năng cấu hình DDNS và việc thiết lập cũng không quá khó.

Cấu hình DDNS trên router Mikrotik TRÊN DNS WEBSITE: OS.GFTTH.COM

VIDEO HƯỚNG DẪN:

 

Tiếp đó vào System -> Scripts -> Scripts chọn Add New, Name: os hoặc có thể cấu hình dựa trên Winbox

Code:

:local inetinterface “pppoe-out1”
#————————————————————————————
# Dien so ID cua modem khach hang tao tren os.gftth.com
:global previousIP
:local url “http://os.gftth.com/os.php\3Fip=$previousIP”
/tool fetch url=($url . “&kh=158&cmd=update”)
:if ([/interface get $inetinterface value-name=running]) do={

# IP atual na interface
:local currentIP [/ip address get [find interface=”$inetinterface” disabled=no] address]
# Retira a máscara da rede do endereço IP
:for i from=( [:len $currentIP] – 1) to=0 do={
:if ( [:pick $currentIP $i] = “/”) do={
:set currentIP [:pick $currentIP 0 $i]
}
}
:if ($currentIP != $previousIP) do={
:log info “GFTTH-VIETNAM: Current IP $currentIP is not equal to previous IP, update needed”
:set previousIP $currentIP
}
} else={
:log info “GFTTH-VIETNAM: Previous IP $previousIP is equal to current IP, no update needed”
}
} else={
:log info “GFTTH-VIETNAM: $inetinterface is not currently running, so therefore will not update.”
}

 

Giải thích: 00 Là ID của khách hàng khi tạo trên web: www.os.gftth.com

Lập lịch chạy cho script vừa tạo để luôn làm mới DDNS,

System -> Scheduler

Name: os

Code:

/system script run os

Làm theo hình ảnh

🏡 Địa chỉ: Đội 3, thôn Phú Hạ, Xã Minh Phú, Huyện Sóc Sơn, Hà Nội.
☎️ Mobile/Zalo/Facebook : (08) 18000446 / 0978671166
🌏 Website : http://gftth.com/ Email: gftthvietnam@gmail.com
🌏 Kệnh Fb Cty: Gftth.com.Telecom/ | Kênh Youtube: GFTTH VIỆT NAM TV
🍓 facebook cá nhân : Gftthvn

Tin Liên Quan